#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m) *(.*) +?\n*$"
Local $sString = "first line... abc " & @CRLF & _
" second is here... def " & @CRLF & _
"" & @CRLF & _
" fourth line... hi there " & @CRLF & _
"" & @CRLF & _
" sith is here.... "
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)