# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((CAV-\d\s)[AGCT]+)(?:\n\2[AGCT]+)*/\1/g;t' <<< "CAV-1 ATCTACTTCTATCG
CAV-2 GCGCGTAGCTAGCT
CAV-2 AAGCGCTCGTAAAA
CAV-2 AAGCGCTCGTAAAA
CAV-2 AAGCGCTCGTAAAA
CAV-3 AAATATATATATCC"