re = /((CAV-\d\s)[AGCT]+)(?:\n\2[AGCT]+)*/
str = 'CAV-1 ATCTACTTCTATCG
CAV-2 GCGCGTAGCTAGCT
CAV-2 AAGCGCTCGTAAAA
CAV-2 AAGCGCTCGTAAAA
CAV-2 AAGCGCTCGTAAAA
CAV-3 AAATATATATATCC'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result