use strict;
my $str = 'CAV-1 ATCTACTTCTATCG
CAV-2 GCGCGTAGCTAGCT
CAV-2 AAGCGCTCGTAAAA
CAV-2 AAGCGCTCGTAAAA
CAV-2 AAGCGCTCGTAAAA
CAV-3 AAATATATATATCC';
my $regex = qr/((CAV-\d\s)[AGCT]+)(?:\n\2[AGCT]+)*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";