#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((CAV-\d\s)[AGCT]+)(?:\n\2[AGCT]+)*"
Local $sString = "CAV-1 ATCTACTTCTATCG" & @CRLF & _
"CAV-2 GCGCGTAGCTAGCT" & @CRLF & _
"CAV-2 AAGCGCTCGTAAAA" & @CRLF & _
"CAV-2 AAGCGCTCGTAAAA" & @CRLF & _
"CAV-2 AAGCGCTCGTAAAA" & @CRLF & _
"CAV-3 AAATATATATATCC"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)