import re
regex = re.compile(r"((CAV-\d\s)[AGCT]+)(?:\n\2[AGCT]+)*")
test_str = ("CAV-1 ATCTACTTCTATCG\n"
"CAV-2 GCGCGTAGCTAGCT\n"
"CAV-2 AAGCGCTCGTAAAA\n"
"CAV-2 AAGCGCTCGTAAAA\n"
"CAV-2 AAGCGCTCGTAAAA\n"
"CAV-3 AAATATATATATCC")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)