const regex = new RegExp('((CAV-\\d\\s)[AGCT]+)(?:\\n\\2[AGCT]+)*', 'g')
const str = `CAV-1 ATCTACTTCTATCG
CAV-2 GCGCGTAGCTAGCT
CAV-2 AAGCGCTCGTAAAA
CAV-2 AAGCGCTCGTAAAA
CAV-2 AAGCGCTCGTAAAA
CAV-3 AAATATATATATCC`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);