import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((CAV-\\d\\s)[AGCT]+)(?:\\n\\2[AGCT]+)*";
final String string = "CAV-1 ATCTACTTCTATCG\n"
+ "CAV-2 GCGCGTAGCTAGCT\n"
+ "CAV-2 AAGCGCTCGTAAAA\n"
+ "CAV-2 AAGCGCTCGTAAAA\n"
+ "CAV-2 AAGCGCTCGTAAAA\n"
+ "CAV-3 AAATATATATATCC";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}