# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\.(?!mp3)|[!&^?:;\/]))/$1\n/gm;t' <<< "Hello! Here is a file. It is called beatles.mp3. And so on!"