import re
regex = re.compile(r"((?:\.(?!mp3)|[!&^?:;/]))", flags=re.MULTILINE)
test_str = "Hello! Here is a file. It is called beatles.mp3. And so on!"
subst = "$1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)