use strict;
my $str = 'Hello! Here is a file. It is called beatles.mp3. And so on!';
my $regex = qr/((?:\.(?!mp3)|[!&^?:;/]))/mp;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";