const regex = /((?:\.(?!mp3)|[!&^?:;/]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\.(?!mp3)|[!&^?:;\/]))', 'gm')
const str = `Hello! Here is a file. It is called beatles.mp3. And so on!`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);