$re = '/((?:\.(?!mp3)|[!&^?:;/]))/m';
$str = 'Hello! Here is a file. It is called beatles.mp3. And so on!';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;