using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\.(?!mp3)|[!&^?:;/]))";
string substitution = @"$1\n";
string input = @"Hello! Here is a file. It is called beatles.mp3. And so on!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}