package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^ab\r\n(]*([ab])?[^ab(\r\n]*)\(([0-9]*)\)|(.)`)
var str = `kau(77)j8g(99)sib(88)a21(5)w
kau(77)j8g(99)sib(88)a21(5)wkau(77)j8g(99)sib(88)a21(5)w`
var substitution = "["$1" "$2" "$3"]"
fmt.Println(re.ReplaceAllString(str, substitution))
}