import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^ab\\r\\n(]*([ab])?[^ab(\\r\\n]*)\\(([0-9]*)\\)|(.)";
final String string = "kau(77)j8g(99)sib(88)a21(5)w\n"
+ "kau(77)j8g(99)sib(88)a21(5)wkau(77)j8g(99)sib(88)a21(5)w";
final String subst = "[\"$1\" \"$2\" \"$3\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}