import Foundation
let pattern = #"([^ab\r\n(]*([ab])?[^ab(\r\n]*)\(([0-9]*)\)|(.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
kau(77)j8g(99)sib(88)a21(5)w
kau(77)j8g(99)sib(88)a21(5)wkau(77)j8g(99)sib(88)a21(5)w
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"["$1" "$2" "$3"]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)