# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^ab\r\n(]*([ab])?[^ab(\r\n]*)\(([0-9]*)\)|(.)"
test_str = ("kau(77)j8g(99)sib(88)a21(5)w\n"
"kau(77)j8g(99)sib(88)a21(5)wkau(77)j8g(99)sib(88)a21(5)w")
subst = "[\"$1\" \"$2\" \"$3\"]"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.