// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^ab\r\n(]*([ab])?[^ab(\r\n]*)\(([0-9]*)\)|(.)").unwrap();
let string = "kau(77)j8g(99)sib(88)a21(5)w
kau(77)j8g(99)sib(88)a21(5)wkau(77)j8g(99)sib(88)a21(5)w";
let substitution = "[\"$1\" \"$2\" \"$3\"]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}