# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img[^>]+src="[^"]*?([^\/"]+)\.gif"[^>]*>/:$1/gi;t' <<< "<img src=\"../../images/smiles/D.gif\" alt=\"image\" />
<img src=\"m.gif\" alt=\"image\" />"