package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<img[^>]+src="[^"]*?([^/"]+)\.gif"[^>]*>`)
var str = `<img src="../../images/smiles/D.gif" alt="image" />
<img src="m.gif" alt="image" />`
var substitution = ":$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}