using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[^>]+src=""[^""]*?([^/""]+)\.gif""[^>]*>";
string substitution = @":$1";
string input = @"<img src=""../../images/smiles/D.gif"" alt=""image"" />
<img src=""m.gif"" alt=""image"" />";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}