re = /<img[^>]+src="[^"]*?([^\/"]+)\.gif"[^>]*>/i
str = '<img src="../../images/smiles/D.gif" alt="image" />
<img src="m.gif" alt="image" />'
subst = ':$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result