// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<img[^>]+src="[^"]*?([^/"]+)\.gif"[^>]*>"#).unwrap();
let string = "<img src=\"../../images/smiles/D.gif\" alt=\"image\" />
<img src=\"m.gif\" alt=\"image\" />";
let substitution = ":$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}