import Foundation
let pattern = #"<img[^>]+src="[^"]*?([^/"]+)\.gif"[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<img src="../../images/smiles/D.gif" alt="image" />
<img src="m.gif" alt="image" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)