#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)<img[^>]+src="[^"]*?([^/"]+)\.gif"[^>]*>"
Local $sString = "<img src="../../images/smiles/D.gif" alt="image" />" & @CRLF & _
"<img src="m.gif" alt="image" />"
Local $sSubst = ":$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)