$re = '#<img[^>]+src="[^"]*?([^/"]+)\.gif"[^>]*>#i';
$str = '<img src="../../images/smiles/D.gif" alt="image" />
<img src="m.gif" alt="image" />';
$subst = ":$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;