#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?(?:_.*?){3})(?=_|$).*$"
Local $sString = "ABCD01MAH_processor_B_stats_qwer_20181105T105946Z.csv" & @CRLF & _
"ABCD01MAH_processor_B_stats_qwer_20181106T105945Z.csv" & @CRLF & _
"EFGHIJ01MAH_processor_A_stats_qwer_20181105T105945Z.csv" & @CRLF & _
"EFGHIJ01MAH_processor_A_stats_qwer_20181106T105945Z.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")