const regex = /^(.*?(?:_.*?){3})(?=_|$).*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?(?:_.*?){3})(?=_|$).*$', 'mg')
const str = `ABCD01MAH_processor_B_stats_qwer_20181105T105946Z.csv
ABCD01MAH_processor_B_stats_qwer_20181106T105945Z.csv
EFGHIJ01MAH_processor_A_stats_qwer_20181105T105945Z.csv
EFGHIJ01MAH_processor_A_stats_qwer_20181106T105945Z.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}