import re
regex = re.compile(r"^(.*?(?:_.*?){3})(?=_|$).*$", flags=re.MULTILINE)
test_str = ("ABCD01MAH_processor_B_stats_qwer_20181105T105946Z.csv\n"
"ABCD01MAH_processor_B_stats_qwer_20181106T105945Z.csv\n"
"EFGHIJ01MAH_processor_A_stats_qwer_20181105T105945Z.csv\n"
"EFGHIJ01MAH_processor_A_stats_qwer_20181106T105945Z.csv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")