re = /^(.*?(?:_.*?){3})(?=_|$).*$/m
str = 'ABCD01MAH_processor_B_stats_qwer_20181105T105946Z.csv
ABCD01MAH_processor_B_stats_qwer_20181106T105945Z.csv
EFGHIJ01MAH_processor_A_stats_qwer_20181105T105945Z.csv
EFGHIJ01MAH_processor_A_stats_qwer_20181106T105945Z.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end