import Foundation
let pattern = #"^(.*?(?:_.*?){3})(?=_|$).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABCD01MAH_processor_B_stats_qwer_20181105T105946Z.csv
ABCD01MAH_processor_B_stats_qwer_20181106T105945Z.csv
EFGHIJ01MAH_processor_A_stats_qwer_20181105T105945Z.csv
EFGHIJ01MAH_processor_A_stats_qwer_20181106T105945Z.csv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)