using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?(?:_.*?){3})(?=_|$).*$";
string input = @"ABCD01MAH_processor_B_stats_qwer_20181105T105946Z.csv
ABCD01MAH_processor_B_stats_qwer_20181106T105945Z.csv
EFGHIJ01MAH_processor_A_stats_qwer_20181105T105945Z.csv
EFGHIJ01MAH_processor_A_stats_qwer_20181106T105945Z.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}