using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+)(\n\1)+";
string substitution = @"$1";
string input = @"Desarrollo
Desarrollo
Desarrollo
Desarrollo
Desarrollo
Publicados
Publicados
Publicados
Publicados
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Funciones
Funciones
Funciones
Utilidades
Utilidades
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}