import Foundation
let pattern = #"(.+)(\n\1)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Desarrollo
Desarrollo
Desarrollo
Desarrollo
Desarrollo
Publicados
Publicados
Publicados
Publicados
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Funciones
Funciones
Funciones
Utilidades
Utilidades
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)