use strict;
my $str = 'Desarrollo
Desarrollo
Desarrollo
Desarrollo
Desarrollo
Publicados
Publicados
Publicados
Publicados
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Funciones
Funciones
Funciones
Utilidades
Utilidades
';
my $regex = qr/(.+)(\n\1)+/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";