import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+)(\\n\\1)+";
final String string = "Desarrollo\n"
+ "Desarrollo\n"
+ "Desarrollo\n"
+ "Desarrollo\n"
+ "Desarrollo\n"
+ "Publicados\n"
+ "Publicados\n"
+ "Publicados\n"
+ "Publicados\n"
+ "Experimentos\n"
+ "Experimentos\n"
+ "Experimentos\n"
+ "Experimentos\n"
+ "Experimentos\n"
+ "Experimentos\n"
+ "Experimentos\n"
+ "Experimentos\n"
+ "Experimentos\n"
+ "Respuestas\n"
+ "Respuestas\n"
+ "Respuestas\n"
+ "Respuestas\n"
+ "Respuestas\n"
+ "Respuestas\n"
+ "Respuestas\n"
+ "Funciones\n"
+ "Funciones\n"
+ "Funciones\n"
+ "Utilidades\n"
+ "Utilidades\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}