$re = '/(.+)(\n\1)+/';
$str = 'Desarrollo
Desarrollo
Desarrollo
Desarrollo
Desarrollo
Publicados
Publicados
Publicados
Publicados
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Funciones
Funciones
Funciones
Utilidades
Utilidades
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;