const regex = new RegExp('(.+)(\\n\\1)+', 'g')
const str = `Desarrollo
Desarrollo
Desarrollo
Desarrollo
Desarrollo
Publicados
Publicados
Publicados
Publicados
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Experimentos
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Respuestas
Funciones
Funciones
Funciones
Utilidades
Utilidades
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);