# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.+)(\n\1)+"
test_str = ("Desarrollo\n"
"Desarrollo\n"
"Desarrollo\n"
"Desarrollo\n"
"Desarrollo\n"
"Publicados\n"
"Publicados\n"
"Publicados\n"
"Publicados\n"
"Experimentos\n"
"Experimentos\n"
"Experimentos\n"
"Experimentos\n"
"Experimentos\n"
"Experimentos\n"
"Experimentos\n"
"Experimentos\n"
"Experimentos\n"
"Respuestas\n"
"Respuestas\n"
"Respuestas\n"
"Respuestas\n"
"Respuestas\n"
"Respuestas\n"
"Respuestas\n"
"Funciones\n"
"Funciones\n"
"Funciones\n"
"Utilidades\n"
"Utilidades\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.