#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)--target=([^\s]*)|--driver=([^\s]*)|(.*) #"
Local $sString = "test_drive/main.dart # default behavior" & @CRLF & _
"--target=test_drive/main.dart # default behavior" & @CRLF & _
"--driver=test_drive/main_test1.dart # runs on lib/main.dart which will not work" & @CRLF & _
"--target=test_drive/main.dart --driver=test_drive/main_test1.dart # offer some flexibility" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")