import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "--target=([^\\s]*)|--driver=([^\\s]*)|(.*) #";
final String string = "test_drive/main.dart # default behavior\n"
+ "--target=test_drive/main.dart # default behavior\n"
+ "--driver=test_drive/main_test1.dart # runs on lib/main.dart which will not work\n"
+ "--target=test_drive/main.dart --driver=test_drive/main_test1.dart # offer some flexibility\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}