re = /--target=([^\s]*)|--driver=([^\s]*)|(.*) #/m
str = 'test_drive/main.dart # default behavior
--target=test_drive/main.dart # default behavior
--driver=test_drive/main_test1.dart # runs on lib/main.dart which will not work
--target=test_drive/main.dart --driver=test_drive/main_test1.dart # offer some flexibility
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end