const regex = /--target=([^\s]*)|--driver=([^\s]*)|(.*) #/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('--target=([^\\s]*)|--driver=([^\\s]*)|(.*) #', 'gm')
const str = `test_drive/main.dart # default behavior
--target=test_drive/main.dart # default behavior
--driver=test_drive/main_test1.dart # runs on lib/main.dart which will not work
--target=test_drive/main.dart --driver=test_drive/main_test1.dart # offer some flexibility
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}