using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"--target=([^\s]*)|--driver=([^\s]*)|(.*) #";
string input = @"test_drive/main.dart # default behavior
--target=test_drive/main.dart # default behavior
--driver=test_drive/main_test1.dart # runs on lib/main.dart which will not work
--target=test_drive/main.dart --driver=test_drive/main_test1.dart # offer some flexibility
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}