package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)--target=([^\s]*)|--driver=([^\s]*)|(.*) #`)
var str = `test_drive/main.dart # default behavior
--target=test_drive/main.dart # default behavior
--driver=test_drive/main_test1.dart # runs on lib/main.dart which will not work
--target=test_drive/main.dart --driver=test_drive/main_test1.dart # offer some flexibility
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}