import re
regex = re.compile(r"--target=([^\s]*)|--driver=([^\s]*)|(.*) #", flags=re.MULTILINE)
test_str = ("test_drive/main.dart # default behavior\n"
"--target=test_drive/main.dart # default behavior\n"
"--driver=test_drive/main_test1.dart # runs on lib/main.dart which will not work\n"
"--target=test_drive/main.dart --driver=test_drive/main_test1.dart # offer some flexibility\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")