// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)--target=([^\s]*)|--driver=([^\s]*)|(.*) #").unwrap();
let string = "test_drive/main.dart # default behavior
--target=test_drive/main.dart # default behavior
--driver=test_drive/main_test1.dart # runs on lib/main.dart which will not work
--target=test_drive/main.dart --driver=test_drive/main_test1.dart # offer some flexibility
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}