#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Language:\s*(\w+)\s*Place:\s*HK"
Local $sString = " Language: English" & @CRLF & _
"" & @CRLF & _
" Place: Seattle" & @CRLF & _
"" & @CRLF & _
" Segments: b,p,m,d,t" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Language: Mandarin" & @CRLF & _
"" & @CRLF & _
" Place: HK" & @CRLF & _
"" & @CRLF & _
" Segments: n,i,o,h" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Language: Cantonese" & @CRLF & _
"" & @CRLF & _
" Place:HK" & @CRLF & _
"" & @CRLF & _
" Segments:l,e,h,o"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")