import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Language:\\s*(\\w+)\\s*Place:\\s*HK";
final String string = " Language: English\n\n"
+ " Place: Seattle\n\n"
+ " Segments: b,p,m,d,t\n\n\n"
+ " Language: Mandarin\n\n"
+ " Place: HK\n\n"
+ " Segments: n,i,o,h\n\n\n"
+ " Language: Cantonese\n\n"
+ " Place:HK\n\n"
+ " Segments:l,e,h,o";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}